Xbox dropped the ball with this latest update!

I never had this many problems with connecting to parties or going online with games since this update.  It all started last week around March 10th with party chat sounding choppy.  I have not changed any equipment since then.  Currently I deal with choppy communications or restarting game many times before it decides to connect.  After a while of being on it decides to clear up and behave like it did before the 10th.  Many people from my area with the same isp have called in with the same problem.  I thought it was my isp but after looking at the forums it looks like its not my isp.

 

Question Info


Last updated July 4, 2018 Views 5 Applies to:

no probably not you isp but possibly your router needing update or your modem got update as well and you need to power cycle your modem and router, thats the good starting point.

here is what you do, tiurn off everything connect to internet and router.

then unplug modem and router wait five minutes plug modem back in wait at least 5 minutes then plug in router wait at least 3 mins and turn xbox on first, that way it has port one, usually internet providers send updates to modems once a week and usually in the am hours sometimes the updates mess with the routers and require them to be reset, try that, I love the update and have had zero issues with them, i also powercycle weekly. hope that helps.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I did the recycle step for the modem and still get the same problem with getting kicked from party or choppy chat.  Other people have called in with the same problem to the isp company.  I spoke with the tech guy today add he has tried talking with xbox with no luck.  I am running with a manual ip and that because the default one has me with a moderate connection.  I am run a modem setting that was set up by a xbox tech guy.  the setting has me running with an open nat type.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.