Xbox Accessories App Install Failure

Hey guys, if there's already a solution to this send me in the right direction...

I installed the Xbox Accessories app on my XBO Elite console, and all appeared well. I tried opening it, and I got an error message (I don't recall a code, if there was I didn't write it down) saying the app needed updating and it was not available right now. This just kept happening, so I tried uninstalling and reinstalling, but when I went to reinstall the download appeared not to start or do anything. I could pin the app to the dash from the store, so I did just to see what was going on, and now we reach the present:

There is a black tile (not green, as it should be) titled Xbox Accessories pinned to my Home screen which gives 3 options; Install, Show in App Store, and Cancel. Install appears to start a download, but nothing appears in the queue. Show in App Store shows the app in the store, with the option to pin/unpin to Home and nothing else. The app doesn't appear in My Apps, and I can find no option anywhere to uninstall it. I can't find the app in the app store by searching either, only by clicking the Show in Store link when I try and open the blank icon.

I've gone offline and restarted a few times, but nothing seems to boot this thing along... any thoughts appreciated, I'd like to be able to map my Elite Controller!

Thanks,

Gareth

 

Question Info


Last updated July 4, 2018 Views 12 Applies to:
Answer

It should came in installed with the Novemebr update. See if you have the latest OS version and build. If not, try to have it updated.

support.xbox.com/.../system-update-operating-system

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.