Xbox 360s wireless keeps defaulting to wireless g

I have a xbox 360s that i got on release day and at that time i only had a router that transmitted wireless G. Now i have a brand new router that i have set to only work on N. Here is the problem i am having.. when i turn my xbox on and check the wireless settings it is showing it being connected by wireless G. If i reset back to factory settings and then reconect to wireless it then changes to Wireless N like it should do.It seems that every time i turn off the xbox and switch it back on the wireless defaults back to G. Has anyone else had this problem on a 360s? and have you fixed the problem? could this be a firmware problem that microsoft needs to address? I have even tried deleating everything off my xbox and restoring to factory defaults, this has not corrected the problem either.Any help would be great.. would be nice to not have to keep resetting the to default settings everytime i turn my xbox back on

 

Question Info


Last updated July 4, 2018 Views 45 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

Please read:- forums.xbox.com/.../811997.aspx

And post back your details in full (the bits that are in bold on that post) so that people may help

If you are wireless can you also state whether you are using the white or black external adapter or the Xbox 360S Internal adapter

Thanks

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yeah i tried all of that what was suggested, and i am using the internal xbox 360s wireless adaptor. I know it's not the router as my son has an external adaptor and his xbox always connects using wireless N.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

You actually need to post back the details from that post into this thread so we can better understand your setup

TIA

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Router brand & model number: BT home hub 3.0

If Wireless, are you using a white or black external adapter, or an internal (Xbox 360S) adapter?Internal adaptor

Things you have tried: Restored to factory defaults on xbox and reset router

Is UPnP Enabled? Yes/no/Unknown Yes

Do you have a NAT error? If so, what is your NAT?No Nat error or codes

Any Error Codes you encounter: none

Who is your ISP(Internet Service Provider)? bt infinity

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks,

So as a test what happens if you try setting the Wireless interface type: to 802.11N 40Mhz on the Home Hub followed by "Apply", will the Internal Adapter connect?

Doing this will switch the Hub to N mode only meaning no Wireless G clients can connect , so this will affect any other Wireless G only clients

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The home hub is set to only allow wireless N. my xbox slim whoever says it is connected by wireless g. my sons xbox that is an origional style xbox 360 with an external adaptor states his is connected by wireless N. This might not be a big problem for some as i can still connect and play on live fine but i know im running at reduced wireless speed on g. This confirmed by running the network test on media centre on xbox. G states ok for standard tv where as when i can get it connected via N i get full bars for hdtv.This is very annoying and seems to be either a software faulty on the 360 as not recognise that the connection is not g. my xbox should not even be able to connect to my router if this was the case

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

Understand what you are saying but your wireless network will be set to b/g/n at the moment, try setting it just to N to see if it will still connect

Its unlikely to be a fault with the 360 and more likely the Homehub, I have seen reports of this before with the homehub to be honest but never got a resolution so if you can try that and let me know I'd appreciate it

I use the same router myself but dont have a slim

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

No my network is set to N on my home hub just N. And i just done another test using my sons external adaptor on my slim and that connects to N all the time even after reboot of xbox. this leads me to think there is a prob with the internal wireless adaptor thinking it is connecting to g when it's not. So at this point i'm either forced to buy a external adaptor or the cheaper option to keep restoring the wireless to factory defaults everytime i turn my xbox on.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Is there any way of doing a hard reset on the xbox like you can on the ps3? like an engineers reset. I have done the restore console to factory state but as being an computer engineer myself know that this dont always reset the hardware to defaults. As when i first got the slim it asked my to configure wireless adaptor, I'm sure it gave me the option of g or n but had to pick g as i was with sky broadband then and they didnt have any wireless n routers.Might be a long shot but i think my console as locked my internal adaptor into g but is still letting it connect through N but at the lower transfer rate.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Do you have anything you can use to test it with streaming HD? Can you try streaming using the external and internal to see if its any different?

To be honest if you don't stream I wouldn't even worry about it if you don't have any actual issues. My first thought was if you are forcing the Homehub into N only mode then a G client won't be able to connect and it must just be the Xbox misreporting the connection type. But.. I've just a test myself. I used a laptop that only has G adapter to connect to the Homehub in N only mode and it still connects which in my eyes it shouldn't

So have you also tried 802.11b/g/n (Recommended) mode?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.