Xbox 360 to hdmi switch no signal

Ok, I have been to the ends of the internet trying to find a clear answer to my issue and nada. I am currently trying to run my xbox 360 elite (2009) via an hdmi switch (monoprice 4X1 HDMI® Switcher w/ Toslink & Digital Coaxial Port (Rev.2) w/ 3D support.). However, I am unable to get a signal, image or sound on my samsung tv or my viewsonic monitor. Now before we all jump to conclusions below is everything I have tried: Verified/troubleshooting/things to note - Xbox works via hdmi to TV and monitor directly - on tv tried all 3 hdmi ports. They work fine when xbox is connected directly - tried with friends 2007 and 2008 xbox (elite and pro models), with the same switch and works perfectly - tried about 10 hdmi cables (28awg and 24awg as was suggested by monoprice rep) - I have done the power cycle thru by turning on each part one by one in different orders - did the whole power on and hold y & rt - changed resolution manually when connected via hdmi to TV and could not get it to register on switch - cleaned hdmi port (not really that dirty) - switch works with PC tower, ps3 and ps4 no issues on monitor and tv - cleared cache as well with no luck - prior to this xbox was hooked up via hdmi to dvi, with component cable in to run optical input for sound to headphones - on tv it will say mode not supported: resolution not supported. Please change the resolution. Xbox set to 1080p and TV is 1080p - monitor screen will turn black then blink to no signal then back to black till eventually I give up after 5 minutes So, does anyone have any suggestions, thoughts, magical powers, ideas on what could be the issue or fix? I think I gave everything I know and tried.
 

Question Info


Last updated July 4, 2018 Views 613 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi, the first thing I would suggest is to go to settings/ system/ console settings/ display and turn off display discovery. Power the xbox off and back on again and see if that then gives you a display.

Bananas !!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Tthanks for the quick reply on this.  I did try disabling and enabling the  display discovery, this however did not work either. Few more things to add: checked all ports on the switch and they do work with other devices. Hooked up system via component and back to switch to see if I can get it to trigger, but this also did not work. Did recently try it on my buddies 720 Panasonic, and we had an image with a green/red tint  for a few seconds before we lost it. Tried all troubleshooting tips again with no luck. Is it possible that there maybe an issue with the port sending sweat signal and just can't handle the handoff to te switch?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have seen instances where the xbox can be a little picky with hdmi cables, have you tried swapping the cable from the hdmi switch to the tv at all ?

Sometimes the cheapest hdmi cable will work when a more expensive one doesn't.
Bananas !!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes, I have tried numerous cables. 2 - 6ft Dynex cables, the HDMI cable that came with the PS4, 2 6ft cables from Monoprice, the Microsoft HDMI Cable, and 3 1.5 foot monoprice cables.

I have tried using different combinations using each of these cables from xbox to switch and switch to tv/monitor.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Could you try something, connect everything up and then take the power cable out of the switch and wait say 10 seconds and reconnect the power cable again, You may then need to switch through the outputs on the switch a few times to see if that kicks things into life.

Bananas !!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Sad to say that this did not work either. Same outcome.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Dang, I did find some reviews that say this switch loses the signal from time to time with some devices and that was a possible fix, Right now I'm struggling a little to think of anything else to suggest other than maybe another brand of HDMI switch but I will keep looking as I'm pretty sure the last thing you want to do is pay out more money.

Bananas !!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just a couple of things to check, you're not using a receiver at all ?

.

Check in the display settings on the console, do you have a PAL option, is that set to PAL60 not PAL50

-

When you do check in the display settings is the console reporting you're using a DVI connection even with the HDMI cable connected ?

Bananas !!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Can you please try this in its respective order? Unplug the switch and turn off all the devices, including the TV and source devices (main devices connected to the switch Remove all cables from the switch Turn back on the switch and then the TV Change the HDMI cable from the device you are experiencing issues with Plug it into port 1, then try 2, 3, 4, till you find one that syncs with the TV.

-

Found this on the monoprice feedback section.

Bananas !!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Bananas !!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.