Xbox 360 Slim Stuck in "Ethernet Mode"

I'm not sure if this was the right place but to heck with it. I noticed this a couple days ago and now can't connect to XBL because of it. So you can see my issue. As you know the slims come with a built in wireless adapter, so the first thing I thought to do was to just connect through wireless. I unplug my Ethernet cable and then notice that my Xbox still insists that the cable is actually still plugged in. I plug my Ethernet cable back in, test my connection to XBL, and it fails. It has been giving me a funky IP address as well, something along the lines of 169.xxx.xxx. I thus, can't connect to XBL because even when the Ethernet cable is plugged in, I still can't connect. I know it's not the router because I had my room mate try it with his slim and it worked just fine. I went to the Shack and bought a USB to Ethernet adapter, thought that might work. Wrong. So I'm left with literally nothing. Is there something I haven't tried that MAY work. Anything at this point would be amazing. If anyone has any suggestions or heck, a fix to this problem, please comment.

 

Question Info


Last updated July 4, 2018 Views 0 Applies to: