Xbox 360 S 4GB won't connect to Xbox Live

Hello, I just purchased an Xbox S 4GB console, and it just wont connect to the internet.

 

I have a Netgear WNDR3700v2 router, and everything else seems to be working fine (wirelessly & wired), including my 2 older model 360's.

 

I manually added all the suggested ports for the 360, enabled UPnP, and still no avail.

 

It even won't connect to my neighbors open network, which all my wireless products can do with no issue.

 

I'm starting to think its just this new model that's the issue, because everything else works besides it.

 

I live out in a rural area, and my ISP is not great, but it's manageable. The "modem" is this tiny piece of plastic, looks ghetto, but it has been working all right so far.

 

Please help me, I'm going crazy. My old 360 worked perfectly before I set this one up.

 

Question Info


Last updated July 4, 2018 Views 4 Applies to:

What exact error message are you receiving when you run a LIVE connection test?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.