Xbox 360 not working

I was playing a game earlier, and my xbox just shut off on me, and the power brick light was red.

I unplugged everything, tried plugging the brick back up, and the light was yellow. Then plugged it in to my xbox, still yellow. Tried to turn on the xbox, the lights around the power button blinked one time, then nothing, and the brick light was red again. Then started over again, and hit the eject button instead of the power button, with the same result.

Went to Gamestop and tried out another power brick with the slim hope that it might just be that, as I expected, same result.

So long story short, is this a common problem? It's an xbox 360 arcade, that I've had since Christmas 2008, so it's been awhile, so I'm not super surprised, I'm just wondering if there's anything I can do, short of buying another system? Or is mine just simply fried?

Any help would be appreciated, thanks in advance. :)

 

Question Info


Last updated July 4, 2018 Views 1 Applies to:

If multiple power bricks are behaving the same way, the console is in need of repair. You can set one up here: support.xbox.com/.../repair-process

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.