Xbox 360 Energizer Power & Play Charge Cable suddenly doesn't want to work.

Hello and please help me with this problem,with information telling me if there is something i must do or if there is a problem with the thing. For 3 months it has worked fine,I didn't have to use batteries for my controller I just had to use the cable and I was able to play my games,but now for some odd reason i plug the power and play charge cable into the USB port and I plug the other end into the controller and all I get is a light that stays for a second,from the end that plugs into the controller and that's it I get nothing I tried my friends one and it worked fine but mine now sort of bite's so if you can help me I would appreciate it.

 

Discussion Info


Last updated July 4, 2018 Views 4 Applies to:

Yeah i think it might be broken mate. Try taking the batteries out or if you already have, try puting them back in.

Sweet i found out that my controller just started rejecting the cord so thanks for all the help guys.