XBL Does Not Connect On Cold Boot

The title pretty much says it all.  XBL does not connect on start up and and usualy I need to run a network connection test before it works.

The Basics:

What Country/State/Province do you live in?  Renton, WA
Modem brand & model number:  RCA DHG563C
Router brand & model number: Cisco IOS Software, C870 Software (C870-ADVSECURITYK9-M), Version 12.4(15)T13
Network Connection Type: Wired
If Wireless, what type of encryption are you using? N/A
Things you have tried: Researched forum and community for similar issues.
Is UPnP Enabled? No
Is NAT Type Open? No
Any Error Codes you encounter: Unable to connect to XBL on cold boot
What type of internet do you have? Cable
Who is your ISP(Internet Service Provider)? Comcast
When you run "Test Xbox LIVE connection" what is the exact message shown on screen 9/10 times it connects, and if it fails I rerun untill it connects.

Details:

interface FastEthernet4
 description Internet Interface
 ip address dhcp
 no ip redirects
 ip nat outside
 ip virtual-reassembly
 no ip mroute-cache
 duplex auto
 speed auto
 no cdp enable

interface Vlan1
 ip address **RFC1918** 255.255.255.0
 ip nat inside
 ip virtual-reassembly

Xbox staticly assigned, and IP space excluded:

ip dhcp pool local
   network **RFC1918** 255.255.255.0
   default-router **RFC1918**
   dns-server 8.8.8.8 8.8.4.4

ip dhcp excluded-address **RFC1918** **RFC1918**

XBL Ports Forwarded:

ip nat inside source static udp **RFC1918** 88 interface FastEthernet4 88
ip nat inside source static udp **RFC1918** 3074 interface FastEthernet4 3074
ip nat inside source static tcp **RFC1918** 3074 interface FastEthernet4 3074
ip nat inside source static tcp **RFC1918** 53 interface FastEthernet4 53
ip nat inside source static udp **RFC1918** 53 interface FastEthernet4 53
ip nat inside source static tcp **RFC1918** 80 interface FastEthernet4 80

 

Question Info


Last updated July 4, 2018 Views 10 Applies to:

I would post this in forum #2

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Anyone have any thoughts on this?  It seems very strange that it only seems to have issues on cold boot, and when a connection test is run it works fine.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

When did this issue start occurring? Was there a period of time in which this did not happen upon startup?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm not aware of any changes which immediately impacted my ability to connect to XBL.  There was a few months where I didn’t even turn on my Xbox, and during that time a major XBL update was released and I also updated my router.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It's possible the router update could have something to do with it; have you since checked to see if any new updates are available for your router?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

There have been no MD releases of the cisco IOS for this make/model.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

conf t

 

interface FastEthernet4

spanning-tree portfast

end

 

wr

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

GREAT sugestion Shad0wmanUK!

For anyone that looks up this post in the future.

Post-Mortem:

Problem existed because my Xbox was directly connected to my Cisco 800 series router(Full IOS), and the way Cisco handles enabling ports.

Detailed Explanation:

By default on Cisco Catalyst switches, both PAgP (used for EtherChannel negotiation) and DTP (used for trunk negotiation) are enabled, which increases the amount of time a port takes to initialize before forwarding data. You should also eliminate these sources of delay if you do not need EtherChannel bundles or trunks to form on your ports attached to workstations.

Before configuring PortFast, you must carefully consider which ports you are going to enable it for. It is recommended that you enable it only for ports that are connected to workstations, because it is very unlikely attaching these devices introduces loops in the network. Do not configure PortFast on ports that connect to other Layer 2 devices, such as a hub, bridge, or switch, and do not configure the feature on ports attached to servers and routers, because these devices are normally up at all times. If you do enable PortFast on a port that is attached to another switch and a loop is detected, the switch immediately blocks the port; however, there is a danger that it could be too late because the switch might already be overwhelmed by a broadcast storm. For this reason, PortFast should only ever be used on ports that are connected to a single host, because this ensures a loop could never be formed.

Resolving the issue:

A slight alteration was made to the sugestion by Shad0wman, and portfast was made on FastEthernet1(Port cabeled DIRECTLY to my xbox.

Configs:

ROUTER#conf t

Enter configuration commands, one per line.  End with CNTL/Z.

ROUTER(config)#int f1

ROUTER(config-if)#spanning-tree portfast

%Warning: portfast should only be enabled on ports connected to a single host.

Connecting hubs, concentrators, switches,  bridges, etc.to this interface

when portfast is enabled, can cause temporary spanning tree loops.

Use with CAUTION

%Portfast has been configured on FastEthernet1 but will only

have effect when the interface is in a non-trunking mode.

ROUTER(config-if)#end

ROUTER#wr

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Sorry yeah I didn't know which was the port connected to your Xbox, after another read f4 is obviously your internet facing port, glad your all sorted

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.