XB1 Surround Sound Issue

Heading to forums since Xbox service has been of no help. I'm running my XB1 via HDMI into my Samsung TV and then optical out from my TV to my Samsung receiver. Xbox, PS3, PS4, Wii U and cable box all outputting fine in surround sound. However, XB1 gives me the error 0x80bd009 when attempting to select 5.1. I can change the Display settings from Auto-Detect to regular HDMI and it will allow me to select 5.1, but I'm not getting center-speaker audio (dialogue, certain sound FX, etc.). Anybody know a solution for this? Seems odd that it's working fine on five other devices. Thanks in advance!

 

Question Info


Last updated July 4, 2018 Views 44 Applies to:

The Xbox One doesn't currently output surround sound. However, Microsoft is working on it and will be updating the Xbox One to output in surround sound soon.

support.xbox.com/.../digital-sound-not-working

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

That's simply incorrect. The Xbox One has output surround sound since its release-- DTS and 5.1/7.1 uncompressed multichannel PCM over HDMI.  Until the last update, it did not support outputting a compressed Dolby Digital bitstream, which is what is needed for optical (because optical can't carry uncompressed 5.1/7.1).  It does now, however.

OP, it sounds like you are selecting 5.1/7.1 uncompressed, which is not supported by TVs (that is for a receiver (AVR))--and that is why you can't select it when HDMI is set to Auto.  Most likely your TV is just seeing it as 2.0 (stereo) audio.  You need to set the Xbox One audio to bitstream with Dolby Digital encoding.  Even then, please be aware that very few TVs pass DD 5.1 from an HDMI source out though the optical out.  What you may end up getting is virtual surround sound, not true discrete 5.1.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

i have the same code and problem and i have it going to a ONKYO HD receiver... so i'm not pass it thru the tv first..

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.