Wireless N only connects to WRT400N with G

What Country/State/Province do you live in?USA
Modem brand & model number: Actiontec
Router brand & model number: WRT400N
Network Connection Type: Wireless/Wired Wireless
If Wireless, what type of encryption are you using? WPA2
Things you have tried:
Is UPnP Enabled? Yes/no/Unknown Yes
Is NAT Type Open? Enabled
Any Error Codes you encounter: none
What type of internet do you have? Cable/DSL/T1/3G? DSL
Who is your ISP(Internet Service Provider)? ATT
When you run "Test Xbox LIVE connection" what is the exact message shown on screen?Can't connect

 

I hope this hasn't been asked here before, (and I have the right forum) I did some searching but couldn't find anything pertinent to my problem.

I recently purchased the linksys WRT400N router so I could stream Netflix. When I installed it I also opted to upgrade WEP to WPA2 for added security. After installing it and getting Bluray to stream Netflix (which it does beautifully) I set about hooking my Xbox 360. My old adapter could not handle the WPA2 encryption so I ordered the Microsoft Wireless N. On hooking it up I found it could only see the 2.4GHz and not the 5GHz. The router is simultaneous dual band. When connecting it connects to the 2.4 on G not N. This is fine for basic gaming and such, but it wont stream media very well. I tried and it simply won't cut it. I've tried just about everything I can think of: Enabling/Disabling the SSID broadcast, manually changing the channels instead of AUTO, but the XBOX will not "see" the 5G WIFI. Also changed the router to "N only" and the adapter still connects, but the XBOX says its using G, not sure which to believe. I have also updated the routers firmware (another nightmare). Any help or suggestions would be appreciated.

 

Question Info


Last updated July 4, 2018 Views 3 Applies to:

Hi,

 

Hmm that router hasn't had any firmware updates for a while so I assume your using Ver.1.0.02 build 11 is that right?

 

I would (as a test) disable all wireless security on the router for 2.4Ghz and 5Ghz, ensure the two SSID's are named different (no spaces), disable mac address filtering and then restart the router and try to connect to 5Ghz

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

If you have the router set for "N-only" mode and the xbox adapter is connecting ok.  Then I would suspect the Xbox is just miss-reporting the mode.    Besides, there are only a few very limited situations in which the N mode would make any noticeable difference anyway.   If you want to improve your streaming, try a wired connection or try Powerline adapters.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.