Wireless Controller will not turn on.

Hello everybody, I have a normal wireless 360 controller. I use a nyko rechargeable. The controller sat for awhile and I thought the battery just died so much it didn't have the power to turn the controller on. So I went and bought a new nyko charger cord and battery and it wouldn't even charge, nor turn on. Tried a regular battery pack and new aa batteries. It still wouldn't turn on. any idea's or have you had this issue? Thank you

 

Question Info


Last updated July 4, 2018 Views 5 Applies to:

Hey SonicKillShot,

Have you tried different brands of battery. I have noticed in the past that my controllers don't like off brand and cheaper styled batteries.

It may just be time for a new controller though.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey SKS, did you ever get this resolved?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have two wireless controllers, fresh batteries.  Only one controller works at a time. After testing, I've come to the conclusion: 1. Since the same batteries work in one controller, the case I put the batteries in needs to be replaced, not the entire controller.  I can't find anywhere on the site where I can buy just the battery encasement.  2. If I can't buy just that part, I may have to use a rechargeable set up. But I need more information.  Has anyone experienced this situation before and do you know if it is possible to purchase this part and do you think another battery set up would work?  I'd like to get up and running very soon.  Thanks for your help in advance.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there, VerticalPond074! I'm very sorry to see any issues with your controllers connecting! If you narrowed it down to the encasement that you are using, you will want to reach out to the manufacturer of those. If it is the controller's encasement you are talking about, you will want to set up a repair for that controller through our Online Service Center. This thread is over a year old. If you need further assistance, please post up a new thread detailing what you're running into and troubleshooting you've completed. This way our community can get you the individual support that works best on the forums. :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.