Wireless adapter not working

Hi guys. My brother has a problem with his Xbox 360 Wireless G Networking Adapter.

When plugged in (in any USB port front and back), it will sometimes flash red once, sometimes twice etc.

Sometimes it doesn't even flash at all. I've tried using a USB extension lead on all the ports too but still no luck.

But when I connect it to my computer, a solid red light comes up, so it can't be a hardware failure, can it?

I've also tried it on my Xbox and the same things happens - sometimes it flashes sometimes it does nothing.

Has anyone else experienced this? Anyone got any ideas?

Thanks

 

Question Info


Last updated July 4, 2018 Views 2 Applies to:

Hey there Punish! The red light generally does indicate a hardware failure, especially if it does not work on multiple consoles. I would strongly suggest your brother replace this adapter, or use an alternative connection for his console. Sorry for the hassle here.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.