Why does this not work? Another NAT issue...

I believe I'm portforwarding and everything just right, but I still get strict NAT. 

This is the situation:

Tried plugging the Xbox directly and port-forwarding on the router, worked like a charm.

For practical use though, I need to plug the xbox with ethernet cable via PC to a wireless router. This is where the problem occurs. 

I set static IP for the xbox, bridged the wireless connection on  my PC (avoiding the double NAT problem, right?) , turned on ICS, and configured the router to port-forward to the static xbox IP. Also enabled UPnP. No firewall-settings on router up to cause interruption. Why oh why do I still get strict NAT? I do get internet connection.

Randomly, I also did manage to (briefly) get open NAT by portforwarding to the PC IP only, not the xbox (huh?), but then I was still not able to joining friends' parties etc. 

 

For troubleshooting: I'm on win7, the router is a speedtouch ST780.

 

Question Info


Last updated July 4, 2018 Views 9 Applies to:

Hi,

 

So if you connect direct to the router and use portforwarding it works fine? If so... don't use ICS on the PC with Win 7 use Bridging,  that way the Xbox can still use the ip address you set-up for portforwarding when it was connected direct to the router.

 

If you can get this working ok when connected direct to the router and can bridge Win7 instead of using ICS it should still work, as long as there's no other firewall in use like Zonealarm/Norton/Mcafee etc etc

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for the reply.

Just to clarify, the router it worked with directly is not the same one I'm trying to use now (though I am setting it up the same way with portforwarding, a static IP and Upnp, so this shouldn't matter, right?).  

I am already bridging the connection, but if I turn off the ICS I get an error on the xbox saying I "can't connect to hardware using static IP".

I use Avast on the PC, but it doesn't seem to be blocking the xbox as far as I can tell?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Well depending on what you using Avast has Antivirus and a Firewall

 

Please look at one or both of these guides for help on this set-up:-

 

support.microsoft.com/.../978618

www.unofficialguidetolive.co.uk/xbox-ics-bridging-guide

 

For you I would suggest using the "Bridging" method over ICS, once bridging is working you can look at your NAT settings in more detail

 

Thanks

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Okay, so I set up bridging as described, and the connection works and connects to XBL - however I still get strict NAT.

Tried with UPnP on and off, same result.

Uninstalled Avast and got Microsoft Security Essentials running instead. Since it's a microsoft firewall it shouldn't cause any more problems, right?

I really don't know what more to look for, I followed the guide and it "should" work by now - !

Thanks so much for helping.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm trying to set it up like the guide in the second link, but when I get to assigning public IP to a device the xbox doesn't show as an option on my local network?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Did you try the first link first? As its easier to do that way if it works for you, depends on the Speedtouch and firmware really that o2 router is a speedtouch inside

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you, it works now!

I wrecked everything on the first try and had to restore the router to factory default, and now it's all good, open NAT.

Again, thanks so much!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Not a problem, enjoy

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.