why does every forum thread lead me to an error,

trying to find answers to my problems for xbox live.   every single time, since I bought this thing 2 weeks ago.    Always leads me to a " you found a glitch..."

really annoying.   is this just me?

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

is happening with me for a while too!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

me too, if I use open in new tab, but not if just click on link???  Must be a forum thing.  I guess that will be fixed as well soon!!!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey guys - there was a bit of a forum hiccup today, but all should be good now. Apologies for the inconvenience!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Miss Portia, thanks for the update, much appriciated.  :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.