What have you people done to Netflix?

Someone is trying really hard to convince me to throw Live and the 360 in the trash.  Really hard.  First yall go and cancel the family plan and now you pooch up netflix so its almost unusable.

I come home tonight after work and log in.  An announce popps up (like when a friend logs in) saying "Netflix Updated".  I never told it should our could update anything.  It just decided to do it all on its own.

Now when I fire up netflix, it says this content is restricted by family settings.  WTH?  I never changed anything.  No settings.  Now all of a sudden netflix is requiring me to enter the family password?  Every time its run?  Total BS.  I can't enter it using my Logitech Harmony remote as it has no triggers nor bumpers nor any way to simulate them.  So to run netflix I have to use BOTH an IR remote AND a XB controller.  This is total stupidity.  It never needed this in the past.  I didn't ask for it.  ANd there is no way to turn this junk off.

On top of that the new interface is total junk.  You can only see a few movie thumbnails now.  The preview takes half or more of the screen and is basically worthless.  Its just a dumb UI.

Can this be fixed or reset?  If not, I am done here and with netflix.  I am not putting up with 2 controllers to do what a simple IR remote did, and still have to suffer through the botched UI>

 

Discussion Info


Last updated July 4, 2018 Views 11 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Netflix updated the UI not microsoft. They updated it across all outlets as far as im aware

You don't really have a choice on whether an app gets to update itself, with the exception of not doing it which renders the app unusable.  So, yeah.

Also, have you tried going to the Netflix site and changing the family settings there?

Watched some Netflix last night.  Didn't get any errors/issues.  As bad as it looks aesthetically, I wouldn't quit on a gaming console due to Netflix.

^ Funny you say that about how it looks. My Sony Blu Ray with Netflix start out bad for 10 sec than looks amazing. Xbox Netflix just always looks bad.

I'm having the same trouble with Netflix needing a password whenever it is opened on my son's xbox.  It never needed one before this latest update.  It says, as is mentioned in the first post above, that it is restricted by the family settings.  The family settings have not changed from the previous version of netflix and there is no place I can identify in the family settings to change it so it will allow Netflix to open without a password.  Help would be appreciated.  

^ I have no issues with xbox netflix or ps3 netflix.

Netflix no longer displays in HD on my xbox 360.  It does display in HD on my PS3.  To the people who say they have no issues - are you actually able to get Netflix in HD right now?  Of the people I have talked to (granted its only a handful of friends that I know have both xbox and PS3) 100% of them are having the same problem lately.

I remember when I used Netflix about a year ago, the interface was crap then, I can only imagine how bad it is now.

@NOiSEA Could it be an ISP issue? The connection could be causing HD to not work.

It hadn't occured to me that my ISP would affect xbox speed but not ps3.  I will have to think that over, but the facts are that they are:

- both connected through through ethernet

- my connection tests run at 15-20 MBps

- I know people in 3 other states with the same issue lately and I know for sure that at least 2 of them have different ISP's from me.

Because of these 3 things, I doubt it is my ISP (comcast) but I will look into it.

Edit: And 1 other thing I forgot to mention - This is a new phenomenon - before this week Netflix worked in HD on my 360 just fine and it was my prefered console to watch it on.  Before this week I hadn't watched Netlfix in a few weeks though, so I can't be sure exactly when this started happening.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.