Weird Xbox One Wireless Controller Issues.

So I've had my xbox since December and the controller has worked fine for months. Then last week, or maybe the week before, I downloaded the 2nd controller update to my controller and since it's been acting weird. When it's not plugged in via the USB chord the console acts as if I pushed up on the right stick at 100%. It does this randomly in and out of games but it does not do it while the controller is plugged in. Also, while in the home screen, the controllers a button only seems to intimately work. I have to spam the a button just to get into a game or whatever. So, I assume that this has been caused by the new update to the controller so I've tried to repudiate the controller a couple times but it immediately says the controller has been updated so I don't know how to get the controller to redownload the update. I know I can wipe the console back to factory settings but I'm not sure that includes the controller Anyway, any help will be appreciated.
 

Discussion Info


Last updated July 4, 2018 Views 14 Applies to:

F8L, submit your post to the Xbox One Accessories Forum below, so you can get help quicker from forum experts.  forums.xbox.com/.../4677.aspx