weird play & charge kit problem

Pack was going flat so plugged up the charge cable but noticed that the light went red for about 10sec then went green like its charged. Knew it wasn't so I fiddled around with it still no go.

First I pulled the pack off then put back in went to turn the controller on it wouldn't turn on now oh for F*&k sake, tried a couple times - it wouldn't work, So I thought ok i will put the pack in my other controller hey pristo the controller turned on plugged up the charge cable working as it should (and still is) & the extra funny thing is I put the normal AA battery pack on the original controller and it turned on first time (put play & charge pack onto it to try one more time & NO didn't turn on).

Anyone had this problem before - is my decent controller starting to crap out?

Just seems like a wierd issue to happen.

 

Discussion Info


Last updated September 12, 2018 Views 12 Applies to:

I have one controller that will not charge using the play & charge. Two others work fine. I have no idea why this happens.

I had one of my batteries do like that...blinking on the controller, put it on the charger and the charge light went from red to green, PDQ.  But I left it on there, since I already had a good battery.  Still, I wonder if it'll be fully charged when I use it? 

I had the exact same problem, I could never get it to charge, No I'm just back to using batteries :-)

My friend has that same problem but I the play and charge too but have never had a problem.

I dont know why they dont make a new controller with internal battery sorta like the ps3 or cell phone where u just have to plug it in instead of having that PAGER stuck on the bottom of controller...  Sometime when i charge my controller,  it doesnt charge and have to remove then connect again  to start charge....  AND FOR GODS SAKE, REMAKE THE D-PAD... I got that new controller with the dpad transforms....The top broke off after playing mortal kombat

I have the charging kit and one of my battery packs turns green instantly, but it still charges.

[quote user="RacyJuly1972"]

Pack was going flat so plugged up the charge cable but noticed that the light went red for about 10sec then went green like its charged. Knew it wasn't so I fiddled around with it still no go.

First I pulled the pack off then put back in went to turn the controller on it wouldn't turn on now oh for F*&k sake, tried a couple times - it wouldn't work, So I thought ok i will put the pack in my other controller hey pristo the controller turned on plugged up the charge cable working as it should (and still is) & the extra funny thing is I put the normal AA battery pack on the original controller and it turned on first time (put play & charge pack onto it to try one more time & NO didn't turn on).

Anyone had this problem before - is my decent controller starting to crap out?

Just seems like a wierd issue to happen.

[/quote]  

I have a NEW controller I bought two months ago and it was working fine gave me 3 days of game play before I needed to charge it back up. Ever since this new update hit our systems my controller acts like yours does, 3 seconds full charge, 10 seconds later red light needs to be charged up again. it’s the update that has cause these little issues and I am sure they will fix all issues one day but fro right now we have to deal with it.