Urgent help needed

Just traded in my 250GB slim today for the new Gears of War 3 Limited Editiion console. I transferred my gamer profiles, game saves and some arcade games to a 16GB USB stick.

I plugged the USB stick earlier into the new console so I could move all the data into it. The new console detected it fine and I started transferring everything over. All of a sudden a message pops up saying I need to transfer licenses, etc. so I press ok. But now it won't recognise the USB. Only about 4 games were successfully moved before the message popped up. The rest of my game saves are still stuck in the USB and I can't for the life of me get the console to recognise it again !!!

I've tried plugging the USB into a PC but it won't recognise it either. It makes that little noise that it's detected something but when I go to My Computer there's nothing there. Did my new console break my USB stick and are the rest of my game saves lost forever ???

 

Question Info


Last updated July 4, 2018 Views 2 Applies to:

Have you tried any of the other USB ports on the console? Notably, the ones on the back?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.