Unable to join parties with an Open NAT?

I just started having this problem a few hours ago, I haven't joined any parties for around half or three quarters of a month but it worked fine last time I tried.

My friend and I wanted to play Halo 4 today but it kept saying "cannot connect to party, there may be a network connection issue, your NAT is open and suitable for joining" or something along those lines.

Is it something inside my Xbox or is it a glitch because I just downloaded the new update from Halo 4 a while earlier today, and now it's not working.  My friend also said that her Xbox started acting weird a couple of days ago, around when she downloaded the update, but I don't think that's the case.  While I'm fairly sure it was a game update, I might have missed a console update pop up but I just clicked A without looking, so was their a console update?  If there was, is anyone else having the same problems as me?

I also tried to join other people's parties and I tried to send messages but I can't join their party either.  I'm not sure if my messages are being sent correctly either because my friend said she got a blank message from me but I did type "asdfgv" or something, and no one else replied yet.

If it depends on the location then I live in the Lower Mainland area of BC, Canada.

If this is a NAT problem can someone please simplify how to fix it in case unplugging everything doesn't work?

Thanks :D.

 

Question Info


Last updated July 4, 2018 Views 1 Applies to:

Have you tried to test your connection as described here? support.xbox.com/.../nat-type-strict  

Also this thread is your best resource for technical support issues; forums.xbox.com/.../71416.aspx

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.