Unable to connect to Xbox live!

Unable to play multiplayer live with COD Advanced Warfare, but I'm able to play HALO and other games live. Once in a while COD will work multiplayer live, but very rarely.

When I run the multiplayer test for Xbox One, on a wireless network, I receive the error "You have high packet loss" "Your packet loss is 100%..." 

Here's what I've tried so far...

Rebooting all; modem, router and xbox one

Connected Xbox with cable to switch, same issue.

Connected Xbox with cable to modem directly, issue resolved.

Connecting directly to the modem is not an option and I know you are going to say it's the router, obviously, but why are other games working all the time and why occasionally COD works? There must be a resolve to make this work with the existing router.

I'm not overly network savvy, but tried Enabling DMZ, didn't work and also tried the Port Forwarding. Again, I must stress my ignorance with networking.

What Country/State/Province do you live in? Canada, Ontario
Modem brand & model number:

Router brand & model number: 
Luxul XWR-1750
How many Xbox 360 and Xbox One consoles are connected to this router?: 
Only an Xbox One





Who is your ISP? (Internet Service Provider): Cogeco Cable, Download 54.52Mbps, Upload 9.75Mbps, MTU 1480

 

Question Info


Last updated July 4, 2018 Views 67 Applies to:
Answer

I was able to resolve my issue yesterday after a phone call to Luxul, makers of my wireless router. What I needed to do was install an earlier version of firmware and that fixed everything. Hopefully it's as easy at that for you tomtom.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.