Turtle beaches not working

so My turtle beach stealth 500x  are not working in party chat anymore friend can hear me but I cant hear them they work fine in game chat please help i have done all the trouble shooting i can think of this started 2 days ago!!!!!!!!!!!!!!!!!!!!!!!111

 

Question Info


Last updated October 7, 2018 Views 39 Applies to:

Hi there sorry to hear you are having trouble have you tried to reset the headset by holding the mute button down for roughly 10+ seconds or until you hear a loud noise from the headset. After it resets turn it on and it should work like normal. You might need to hard reset your Xbox too if this does not fix it. Let us know if this helps.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm having a similar issue with my Astro A50s... Any advice on that?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm having the same issue with my 500x since last update. . In the Nxoe program.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi all,

I too have experienced the same issue with my 500xs.

My fix is to plug in a wired headset adapter and remove it, I usually chat for a few seconds. I then remove it and switch over to the 500x and it's all working fine. So far this resets between console restarts.

Hope it helps.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Connect them to the controller with the MS adapter and a 2.5mm-3.5mm cable. As soon as you connect them you can remove the cable and it works. Looks like the headset isn't picking up all wireless signals anymore.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.