Turtle beach X12 mic issue

I had the headset connected via adaptor and audio\chat worked just fine, until for some unknown reason the mic just stopped working. When im in a party it shows that i have a mic connected but nobody can hear me. Console/controller are updated and its connected properly (worked fine for awhile) is there some setting that i dont know about? Im about to take drastic measures and reset to factory settings >.<. Oh yea 1 more thing ive also tried another x12 headset to rule out the possibility that its a turtle beach hardware issue , but the mic didnt work with those either. Any help with this would be great

 

 

Question Info


Last updated July 4, 2018 Views 2 Applies to:

Mine had this issue as well. I discovered it was due to the headset adapter "puck" not fitting as snugly in its spot. Due to the lose fit the connections would constantly drop. I could hear them, but no one could hear me. Once I tried puck on my brand new 2nd controller the issues immediately stopped. The puck also snaps in tightly, for now. I have no doubt that after a certain amount of use this controller will also start to loosen up its hold on the puck.  The headset adapter puck is a really poorly designed attachment. Hopefully, that is why they released new controller with headset jack on it.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.