Turtle Beach EarForce XLC - HELP!

I have been using the Turtle Beach EarForce XLC headset for a few days while playing COD Black Ops.  I'm having some problems.  I have my preferences set to "Play Through Speakers" because that is the only way that I can hear people in my party.  I know all about adjusting the GAME settings and Xbox Preferences.  That's not my problem.

My problem is - Even though I'm in a party, I can still hear the other players on my team (who aren't in my party).  I can't talk to them, and my other party members can't hear them, but I can.  When I switch my preferences to "Play Through Headset", I can no longer hear my party members.  Actually, I can't hear anyone.  Does anyone else have this problem???  I've been reading a lot of reviews about these headsets and I haven't seen anyone mention the COD party issue that I'm experiencing.

I want my headset to ONLY play the voices of my party members, not everyone else on my team. 

Here's how I'm set up - I use an HDMI cable from my xbox into my TV.  I have my Turtle Beach hooked up directly into my headphone jack on my tv.  I don't use any red/white audio chords. 

Please help!  I love the headphones, but I can't stand being in a party and having to listen to everyone else on my team.  I only want to hear who is in my party.

 

Discussion Info


Last updated July 4, 2018 Views 23 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

you could try muting everyone else in your party?

Ya know, this might be a dumb suggestion, but I had the exact same problem with my TB's when I first picked them up...and it ended up being that I had the chat cable plugged in backwards (I know, I know).  The L shaped connector should be plugged into the controlled and the straight connector into the headset.

 

Worth a try.  If it does end up being that, change your voice preferences back to play through the headset.

Well, I don't use the splitters that come with the headset because I have a headphone jack on my TV, so my headset is plugged straight into the TV (and it's correctly plugged in, I just checked).  I have my HDMI cable running from my xbox to my HDMI 1 input, and then my headset plugged into the headphone jack.  I tried having the headset plugged into the splitter and then the red/white audio cables hooked up to my HDMI 1 audio jack, but got the same result.  I still had to set my preferences to "Play Through Speakers" in order to hear my party members and could hear everyone else as well.  

A friend of mine has the same headset and he said that his is set to "Play Through Headset" and he can't hear the other players (that aren't in our party).  Whenever I switch mine to "Play Through Headset", I can hear the music and game sounds, but I can't hear my party members.    My screen will show that they're talking, but I can't hear them.  When I switch back to "Play Through Speakers", I can hear my party members AND the rest of the people who aren't in my party.

Any other ideas?

Hmm....I'm not sure what you mean by having your "red/white" cables hooked into your HDMI port.  Have you tried setting your preferences to play through both?

 

I actually think you may need the HDMI Audio Adapter where you can use both your component audio for your headset and HDMI for your video at the same time.

 

I think your problem may lie with connecting the headset directly to the monitor.  Have you tried not using HDMI and using the Component cables instead?  If that works, I'd say that's the problem.

You don't mention plugging the cable into the controller anywhere, you do have that in?

Also, Start a private chat with someone, but don't plug in the controller cable. Set to sound through headset. Get your mate to continually talk. You should hear him through the normal headphones. As he's talking plug in the controller cable, you should hear a bit of a click and then the sound will be back in your headphones. The controller must tell the xbox to switch chat sound from the TV output to the controller output when you plug in, but it sounds like yours isn't. Can you try another controller? What about using a standard chat mic ? will that work? if so I'd suggest your TB are faulty. Do you know anyone else to borrow a pair off to test your setup with?

Up until about 2 nights ago I ran with the standard HD xbox cables. I had the blue, green, (and whatever the other color is) hooked up into my tv. I also had the red/white chords hooked into the TB splitter and was running off of that. After fiddling with it for a while I decided to try the HDMI route and unplugged the xbox chords all together. It worked fine with my regular xbox headset, but as soon as I hook up the TBs i can begin to hear everyone.

Thanks for the suggestions. If I can't get these to work then I'll probably make a run to get the X11 headphones.

As soon as you hook up the TB you hear everyone.. is that with the cable from the TB into your controller too?

I'm having the same problem, I have my headset hooked up to the controler but not the t.v. Do i need a Stereo Splitter Cable?

[quote user="Breto31"]

Up until about 2 nights ago I ran with the standard HD xbox cables. I had the blue, green, (and whatever the other color is) hooked up into my tv. I also had the red/white chords hooked into the TB splitter and was running off of that. After fiddling with it for a while I decided to try the HDMI route and unplugged the xbox chords all together. It worked fine with my regular xbox headset, but as soon as I hook up the TBs i can begin to hear everyone.

Thanks for the suggestions. If I can't get these to work then I'll probably make a run to get the X11 headphones.

[/quote]

Try MW2. see if it's the same or any other game you wish not to talk to anyone. LOL It might be your setting in the game.

Is it coming out of your game Volume? I have X11's. I can turn down/off Chat and turn up Game volume with out hearing anyone.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.