Trouble joining Xbox Live matches

Hey

I recently changed my internet provider from Sky to Virgin (don't ask me why, it wasn't my decision). Anyway now when i connect to Xbox Live I sign in perfectly fine, I can join my friends parties and chats. The only problem i am having is when i try to join an online game I can't connect to any. For example when i play bad company two i get a message telling me: Failed to connect to EA online. And when i try playing games like modern warfare or halo it just won't find any players. I have gold membership and have tested my connection countless times.

i forget to mention that i only get this problem when using my 360 wireless adapter. when i connect using an Ethernet cable it all works fine. 

Is there anyone that can help me

thanks to anyone in advance

x

 

Question Info


Last updated July 4, 2018 Views 4 Applies to:

Hi, when you run the Xbox live connection test what is your NAT status? Are you using the new Virgin Superhub (Cable connection) or Virgin ADSL (National)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey

I just checked and I am using the new Virgin super hub

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

And what about when you run the Xbox live test when wireless does it complain about NAT?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Nope, when I'm on wireless it acts exactly the same as when i use the Ethernet cable, only difference is when I'm wireless i cant join any online games no matter what game I'm playing

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hmmm that's very strange I've not heard of that one before. The Superhub is a bit problematic but I've not heard of that particular issue before

Have you got the new R30 firmware for the Hub yet? If you power it off for 60 seconds and on again it should auto update:- community.virginmedia.com/.../717999

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I haven't deliberately tried to get the R30 firmware as i don't know what it is or what it does but i have turned my router of for a few minutes at a time to try and see if it would make a difference to my problem

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Its the new version of firmware that has a number of fixes, its always worth getting the latest version of firmware. Apart from a firmware update its hard to know what to recommend with the Superhub to be honest because there's very little information on it, just a few pages on the Virgin website, no real manual to speak of. It sounds like a NAT issue as you can't join a game, but I've not come across NAT issues that are fine wired but not wireless. I would suggest turning off UPnP and setting up portforwarding like this:- portforward.com/.../Xbox_Live_360.htm and see if that helps

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Okay man I will give that a go in the morning and get back to you. Thank you for all your help :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.