Trouble connecting/staying connected to routers

My xbox 360 slim has recently started giving me trouble connecting to routers. I travel a bit so I connect to many routers in hotels. It all used to work without problems. Now when I go to hotels sometimes it will connect one day but not the next. I sometimes try and connect via my phone wifi hotspot, sometimes that will work sometimes it won't connect to the wifi. Even at home with my router that I have played with for the past 6 months it has trouble connecting to it. Usually after disconnecting and reconnecting to my router it will work, but even if it works my connection is good sometimes, and other times it kicks me out of games or lags a lot. Sometimes it completely disconnects me from the router, not just xbox live. I have tried this on many different routers and have the same issues with them.

my router is a netgear WNDR3800 N600

my console is about 1 yr old with the built in wifi

 

Question Info


Last updated July 4, 2018 Views 2 Applies to:

Just a shot in the dark, but have you tried resetting the network settings on the console to factory defaults?

To see if that improves anything?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

What else is using the network at the same time your using your 360?

If you got a bunch of people using laptops and tablets like my family, you'll get lag and disconnects.

My solution was that my router has a QoS option. Here you can give devices preferences on who gets priority on the internet. In our case the 360's IP address would be entered. Check your router admin page. post back for additional help if needed.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have reset the settings to the factory or default settings, didn't seem to make a difference. Also Bird125 it will disconnect me not from the internet, but from the router. It will do it when I am the only one on the network.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.