Thumbnails from game library missing

When I go to my games library on my 360, more than half of the corresponding thumbnails for the games are gone, it's just some stock xbox live pic with a green swirl in it, some have them, most do not. Any help here? And can this post not be deleted...

http://s278.photobucket.com/user/Bark4Soul/media/11774367_10153084988713517_1436708843_n_zps2obhnxzc.jpg.html

Pic showing what I am talking about

 

Question Info


Last updated July 4, 2018 Views 371 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Exact same issue here.  It has spread to the apps as well so now I have to go into app details to make sure I'm launching the one I want.  Any help or advice is greatly appreciated.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey, guys! Sorry to see you're running into this! We've got the right teams looking into the box art right now. Once I have more information for you, I'll be sure to post back in here. :) Thanks for your patience while we look into this!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I tried the clearing of the cache on the hard drive, it fixed some of them and then took away others I had before that, so....this is confusing and annoying, literally, 8 years of having an 360 and it's never done this

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I don't know why this isn't pinned. Clear your cache a few times for a temporary fix.

Basically, if there's no cover art for the game (Due to it being delisted, or a demo, or another reason), it's supposed to load that generic Xbox Live cover. However due to a bug in the system software, it sometimes mistakes cover art for missing art and downloads the generic cover over the real one. Sometimes it realizes that there's art for said game, and redownloads the real one. That's why it switches. Now when people say 'they're working on it', it either means, wait a few months until the next system update, or, they're not actually working on it because that's what they said for delisted pins but those have been broken since pins were released for years now...so yeah.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there, Han! I've been notified that this should be resolved now. Can you go ahead and check your box art and let me know if it's still showing up as your image shows? If so, I'd like to make sure we get the right people aware that it's still not resolved. :)

Irixion - When we say we're working on it, it means the right teams are looking into it. If have further information than that, we will post it. Understand that different issues are resolved with different resolutions, and a system update is not required to resolve every issue. We'd appreciate it if you would let us notify the customers as to what the resolution is once we have word on what that is. Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Not fixed here as of yet.  Only affects a couple games for me but the apps have all but been replaced with the generic xbox live thumb.

i287.photobucket.com/.../DSC_1814.jpg

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The console appears to be downloading covers for what it mistakenly assumes are missing/de-listed covers. It's not solved for me either. Though, I'm seeing the issue temporarily resolve by the proper covers showing up and then being overwritten by the generic ones more often than before. The system software is so sluggish and buggy now. What happened to the quality control? Remember the days of the snappy pre-NXE dashboard? I miss those :(

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am also having the exact same problem. (Its doing it to most of the game/apps I have downloaded) Clearing cache does nothing for me. I even tried deleting the system update, the apps and downloaded it again. And now when I am at the home screen, go to the right and click on the netflix button under the apps tab it opens overview instead of opening netflix directly. This problem should be listed on the xbox.com/status page so we know something is being done about this problem.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having the same problem and it hasn't been resolved.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Clear your cache a few times in a row on ALL of your storage devices. Then reboot your console.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.