There was a problem updating your controller

I received my headset adapter tonight and was excited to finally use my Astro A40s to hear in game surround sound and chat... like I used to on the 360. So, I follow all the instructions in the paperwork and I get:

There was a problem updating your controller

I searched online, tried the power cycling method... tried different controllers, tried different headsets, tried with and without batteries installed. I made sure all the wires were plugged in. Finally I gave up and called MS. I chatted with them for over an hour and they also could not get it to work.

Anyone else had this trouble? The update for sensitivity applied fine. I plugged the controller in and downloaded that update without issue. But if I plug the headset adapter in and plug a wire (from any headset) into the adapter (apparently turning it on) I am prompted to update my controller again (supposedly for the headset adapter) and it never works. I always get this message.

Very frustrated!

 

Question Info


Last updated July 4, 2018 Views 54 Applies to:
Answer

you'll need to return it and get a new one, seems like there is a dodgy batch.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.