Stuck in "Update in Progress"

Just tried to update and now my box is stuck.  I can't get out of the same "update in progress" sequence.  I tried putting the update onto a USB stick, but everytime I power up my system goes directly into "Update in Progress" and then never makes it more than 15% of the way through.  I tried pulling the Ethernet cable, but the same sequence happens.

All I wanted to do was play a simple game tonight, and now I am wasting hours trying to get my box working.  Based upon the number of similar complaints I am seeing on the forum, I think someone may have blown the testing on this update.

What am I supposed to do now?

 

Question Info


Last updated July 4, 2018 Views 4 Applies to:

I just had to walk away from the system, give it about 15 minutes, and it finally finished.  I guess I just got impatient when I saw the progress update bar freeze for a long time in one place.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.