steelseries h chat issues

hi there can anyone help me out setting up a steelseries h wireless headset for xbox chat ive tried got a 2.5mm too a 3.5mm cable for the adapter that doesnt work ive tried adding a profile too still nothing im not even sure if i have the right cable or meant to set up a profile for it if theres is anyone out there that knows how to set this up precisly for xbox and the right cable please can you post here and share your experience please any help would be appreciated thank you

 

Question Info


Last updated July 4, 2018 Views 1 Applies to:

Im having the same problem, I dont know what is wrong

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey, what exactly are your issues as I recently started having issues with mine as well. They worked great for about a year and then one day I joined a party and went to adjust the chat/game mix. Whenever I turn up the chat volume it's like the sound effects for the game turn up with the music on the headset's game channel. I know it sounds really odd. I can barely hear anyone during multiplayer now. Steelseries was unable to help.

If you are just curious how to initially set up your headset to your XBO I can tell you how mine is set up and worked for the first year. I plugged an optical cable from the XBO to the headset's wireless box. I then set up a profile for Xbox on the wireless box. That should give you game audio. To get the chat features you plug the provided cable from SteelSeries from the chat adapter/game controller to the plug on your headset.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there lukewarmchili

Sorry to hear about the headset issues. This particular thread is from last year and the issue has likely been resolved for those who have posted in here. So that you can best get help, please create a new thread rather than bumping older threads. Thanks :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.