Snap Game DVR problem

At least once a day I have to shut down my X1 and unplug the power cord so that I'm able to snap the Game DVR and record longer than 30 seconds. It will work fine for a handful of times but if I come out of the game and watch TV, or anything, returning to the game and trying to snap Game DVR leaves me with a blank gray bar on the right hand side of the screen. It seems like the snap process itself is working, but where the Game DVR options used to be, there's nothing but gray. Just powering off the console and turning it back on doesn't fix the problem either; I have to pull the power cable and restart. Any ideas why this keeps happening?

 

Question Info


Last updated July 4, 2018 Views 10 Applies to:

Hello,

Make sure your console if up to date.  after the update the slip screen will be on left side not on right side of the screen.  If your console is up to date please let me know asap for more help/troubleshoot.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same problem, only difference is I have never used this feature before and tried to use it for the first time but it does not seem to want to work. I checked console updates and it is updated. I only get the grey snap bar on the right of my screen. Would like to be able to use this feature if possible any ideas.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.