Slow Console?

My original Xbox 360 has been acting weird lately. The past month it seems to have a hard time connecting to the wireless in my home. It also has a very hard time loading/downloading items. Just recently I bought some rock band song dlc. It normally downloads a song in just a few minutes, but for the first time it took it literally more than 20 minutes to download three songs for me. I thought maybe it was because of a weak internet connection so i moved it into the same room as my router, and sure enough nothing changed. It still took a large amount of time to download. Is it my console? Because as far as I know it cant be my internet connection. The connection had full bars. I just don't know. I even tried clearing the cache and it didnt help any. Any help?

 

Question Info


Last updated July 4, 2018 Views 1 Applies to:

Hey there! If you want to, you can test your internet connection speeds to see if that could be causing the issue. Please go to http://speedtest.net on a computer on the same network as your console, take the test there, and post the result image back here.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have but even that doesn't work. I don't know what to do. I feel like smashing the console at the moment. The times that I do sign in it says there is stuff it cant show. And other times when I sign in it says there's an error. I've been using this router and Xbox for more than a year so I don't know why it started to act up but I feel like I'm forced to either buy a new console or a new router and both are pretty expensive.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Have you tried a direct connection via ethernet cable? It sounds like there might be some sources of interference in your house that is causing the issue.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.