Slight sound delay when playing games.

So I just got a new Gears of War 3 Special Edition Xbox (or whatever the bloody thing is called), and I started playing Sonic Generations (great game by the way) and whenever Sonic jumps or collects rings, the sound plays like 2 seconds later... So I got up to the time eater and decided to play Battlefield 3 (first timer) I got to where you first use the gun, then there was sound delay in the bullets... Can anyone help me with this? I'm using an HDMI cable on a "SHARP" television. I'm not sure if the HDMI is the problem... Amazing graphics on bf3 though!

 

Question Info


Last updated July 4, 2018 Views 3 Applies to:

Set the TV to Game mode.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The thing is, I can't find a "Game Mode" anywhere in the settings :(

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there Tundra! After a bit of research, it sounds like you should be able to find Game Mode under either the Picture Mode or AV Mode menu. You may have to press this button several times to cycle through the list and find Game Mode. If you can't find it, please refer to your TVs manual or contact the manufacturer to see if they can assist you with finding the option. Let me know if this helps, thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.