Recieving MTU Error, didn't have it before

In the last couple of days when trying to connect to Xbox Live on my Xbox 360, I've been getting an MTU Error. I've never had this error before, and it only started happening last night. I thought it might resolve itself, but it hasn't yet.

I've tried everything in this guide that the console links me to, to no avail: http://support.xbox.com/en-US/xbox-live/connecting/network-insufficient-mtu-setting

I've also tried the top hits on Google when searching for other fixes to the MTU Error.

Here is the info the sticky says I should post, maybe you guys will have a better idea:

What Country/State/Province do you live in? United States, California
Modem brand & model number: N/A, direct ethernet connection provided in my apartment
Router brand & model number: ASUS RT-N13U Rev. B1 with latest firmware installed
Is UPnP Enabled? Yes
Do you have a NAT error? MUT Error, not NAT
Any Error Codes you encounter: No code, just says MTU Error
Who is your ISP(Internet Service Provider)? University provided, and they won't release who the ISP is

W: 0000-000B
X: 0000-F001
Y: 0000-0000
Z: 0000-0000
ID: 0003-0000
L: 0015-10F1
Q: 8007-0435
T: Wired
A: 192.168.1.253/255.255.255.0
G: 192.168.1.1
D: 192.168.1.1/0.0.0.0

Another thing, my router simply runs as an ethernet hub, since we're only provided one ethernet port otherwise.

Thanks in advance for looking at my problem :)

 

Question Info


Last updated July 4, 2018 Views 1,489 Applies to:

Greetings mike!

Have you tried to bypass your ASUS RT-N13U router and make a direct connection to the network socket in your apartment? If you try this, unplug the ASUS router and wait a couple of minutes before you directly connect your console. Start your console and restore network settings to factory defaults. Press "B" on your controller and Test Xbox LIVE connection. Let us know if you still get a MTU error. Thank you!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi taidara, thank's for replying :)

I didn't get the MTU error when directly plugging in, strangely enough. However, putting it back through the router results in the error again. I haven't changed any settings recently, what may be the problem?

Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Do you have the ASUS RT-N13U operating in router mode?

Do you use a stock firmware version? 

What MTU value are set on your router?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes, it is operating in router mode and is using the latest firmware available from the ASUS support site. I'm unsure where to find the MTU value in the settings, or even if it's available.

I just thought of something though, I'm using OpenDNS, could this be an issue?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Try change back the DNS settings to default setting. You do know that google provides a free public DNS service which works great.

Have you tried to power off your router for a couple of minutes?

If the problem persists, try restore your ASUS router to factory settings. Disconnect all devices connected to your router except the power supply. Press and hold the reset button on your router for 10 seconds. Power off your router for one minute. Start your router and wait one minute for it to connect properly. By default UPnP should be enabled but for some ASUS routers it is not, so make sure UPnP is enabled. Apply and reboot your router.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you! After I tried to factory reset, the router went into recovery/panic mode, so I had to reflash the firmware and it worked. Had you not suggested it, I wouldn't be able to connect. Thanks again! :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Happy to hear that you are up and running.

Have a nice weekend and happy gaming!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.