Razer Chimaera 5.1 audio problem?

Is the chat volume on the Chimaera too low or could it be that my headset it defected? The chat volume will only increase with the overall volume, but it's usually drowned by the game audio. Anyone else have issues with this?

 

Discussion Info


Last updated July 4, 2018 Views 133 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

yep, i get the same.

i have set game volume to 1 and voice to 10 in settings and still too quiet.

That's a shame.. It's a great headset, too bad for the very low chat audio...

Mine seems to be the same way.  I got the 5.1's a while ago, the day they first were publically available on Razer's site, and they seemed fine then.  I didn't use them for a few weeks and recently over the past several days I've noticed this issue more and more.  However, there has been an xbox update so I wonder if there was anything with that that is messing with the audio.  Small chance, but maybe.

Either of you guys contact Razer about this?

Nope, i've not had it that long and i normally try to fudge around before i contact manufacturers.

Even scouted about for a 2.5mm to 2.5mm wire with in-line volume control but couldn't find one.

Also butchered my puck cable for my old turtle beaches (snipped off the little pegs by the sides of the jack) that didn't work at all.

I've contacted Razer regarding the issue, they told me to hold mode button for 5 seconds until you hear a beep. (2 beeps is for chat audio, 1 beep for mic) Didn't fix the issue. Voice sound still drowned by game audio. I emailed them back, but haven't received a response for about a week now...

Hi!

I also ordered the Chimaera 5.1 the same day they became available om Razer´s site and I received them in the first batch. I´ve also noticed the low chat volume and contacted Razer about it. I got the same answer as Agent Goomba. This (2 beeps is for chat audio, 1 beep for mic) is not very good described in the manual so I tried to fiddle with it and now the chat volume is definitely loud enough for me. Make sure that you have the 2.5 mm cord connected between the headset and the controller, otherwise fiddling with the chat volume won´t do anything for you. If you still think the chat volume is too low, lower the master volume in the game you are playing, that will make the chat sound stand out louder relative to the game volume.

Another thing I have noticed is that while playing Black Ops, the sound in the headset is a bit "clonky" if you know what I mean (especially when reloading, it sounds like you are in a can). I have the headset base station set to surround sound and the in game audio setting is set to "Surround headphones". If I switch off the surround sound on the Chimaera base station, I loose the 5.1 audio (I only get stereo sound) but the "clonky" sound in the game disapears. Does anyone experience the same thing? Have anyone tried to set the game to "Theatre" instead of "Surround headphones"?

hmm it is connected of course.. I do have voice chat settings set to hear only through the headset since it sounds "cleaner" than having it played through the tv which is what the setting adjustments are for I believe. Could it be that 2.5 cable then? I will try a different one and see if I notice a difference.

Ive got the same issue too. Contacted Razer, no help.

Gunna try a new 2.5mm cable today, will report on my findings later one!

In a roundabout way Im glad you guys have this problem, I was starting to think it was just me and that was making me believe I was insane.

The only thing thats insane is paying £200 for headphones I cant chat to my buddies with :(

@Dao Fei Long - Did the new cable help?

I've recently bought a pair, after not wanting to stump up for Astro's and these getting good reviews, and whilst they are comfortable and sound good the voice volume is forcing me to think about selling these on (as I'm outside of returns and it's not a fault) and either returning to some TB X41's or looking again at the Astro's....

Ok people so PROBLEM SOLVED and you won't believe how...

I decided to go into the game menu for said games and lower the game volume.

I could the max out the volume for the headphones and get nice loud speech volume! If anyone has any more questions about this fix drop me a PM,this forum hates my browser :(

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.