Random connection interruptions and disconnections from Xbox Live parties

I recently got my internet service at my new apartment and I CONTINUOUSLY get lagged out of Xbox Live parties with my friends. Whenever I play Minecraft, I'll be disconnected every 30 minutes or so. Probably the most annoying, when playing COD BO2 I will get a connection interruption that lasts a few seconds, and again, it happens every 30 minutes or so. My NAT is open, but occasionally will drop to moderate. I can easily fix the moderate NAT by resetting my router though.

We have a modem that functions as a router. 11.7 Mbps down, 1 Mbps up. Any help?

 

Question Info


Last updated July 4, 2018 Views 6 Applies to:

I'm getting them as well :(

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm beginning to wonder if it's the DHCP reservation set up on my router. The router is set to automatically assign DHCP reservation for every device connected to the router. It also shows that the IP is leased and renewed every 30 minutes. I'm going to assign a static IP to my Xbox and see if that resolves the issue.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Okay, no dice. But, I have confirmed that this is happening EXACTLY every 30 minutes. So, what I'm thinking is that my router is set to lease/renew IPs every 30 minutes, but I can't find an option for this. Any help?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there Justifis!

Appreciate if you could provide us with a little more information. Please read: START HERE! And post back in full detail (the bits that are in bold).

Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks Taidara, but I've confirmed the issue. My router model (ZyXEL PK5001Z) has a bug that causes the router to request a new IP address from the DHCP server every 15 minutes. My ISP is sending out a replacement router that currently has no issues.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.