"Required storage device removed. Console will restart"

I turn on the 4gb  xbox slim. no hard drive. While the dashboard is loading it may have been a mistake to swap USB drives containing game installs. Next thing I know I get the error message: "Required storage device removed. Console will restart now". Console restarts but now my profile information is gone.

I try to download profile from Xbox Live multiple times, but every time the download bar appears I get the same: "Required storage device removed" message. I then choose an empty USB device and choose to download profiles there. Same error message appears and/or console freezes. That or "A new update is available." Followed by more freezing. After 3rd attempt, the profile download is complete. Except now the xbox dashboard loads, followed by same error message, followed by reboot, over and over unless I pull out the profile-containing USB drive.

I can only access System settings and memory if not signed in to my profile. Also, my 4gb internal memory shows 113mb free out of 3.3gb, but when I select the storage device it shows no files whatsoever.

I have tried to format the 4gb memory, aware I'll lose save files. Yet the same "Required storage device removed. Console restarting" message appears.

Contacted Support, and the immediate and only  response is send for repair: $100.

Has anybody come across this problem? Better yet, has someone resolved it without paying $100-120? It seems more like a software, not hardware issue. But I'm no tech expert. Thanks.

 

Question Info


Last updated July 4, 2018 Views 35 Applies to:

Hey cokes whats happening here is that your 4g doesnt have enough storage space for the most recent update.

Please clear up about 300 mb of space on your 4gb and then boot it up with no storage devices. If you can't do this because it keeps freezing please prevent the xbox from connecting to the internet when it boots by turning off the router or modem you are using.

- Whats happening is the update is being installed to the flash drives because you are out of space and when you pulled the flash out the update went with it.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks man, though your suggestion of disconnecting the router only solves half the problem, constant restarting that is.

As of 24 hours ago the Xbox had the latest updates. If I unplug all USB drives and keep from internet connections, the Xbox runs on the latest dashboard, which look hasn't changed from November I think, almost completely fine except the 4gb internal memory continues to be weird on me. Microsoft support had said it may have been a loose internal memory connection, but it obviously doesn't fail completely. It's just keeping me from choosing what to erase.  It says there's 120ish mbs left but wont show me any files.

And again, attempting format the 4gb internal memory gives the constant "Required storage device removed. Restarting" error.  It's almost as if I'm being locked out of the internal memory. Clearing system cache doesn't help either. If there was a way of rebooting the console (along with the 4gb internal memory) it would probably solve things (I think). Maybe a way to reset the memory without going through the faulty format process. Reboot solutions such as these don't seem too promising for the memory part of the problem: [View:http://www.youtube.com/watch?v=aPT5mzjEFh0]

I don't mind losing save files. It's clearly a software problem, not a hardware like Support is trying to tell me.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

sorry for run-on paragraphs btw

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there Coke! I understand you are having trouble getting your console to load up properly here. It sounds like you've tried out the troubleshooting. At this time I would have to agree with phone support and suggest that you send your console in for repair. You can do this by calling them back or by visiting our online page: How to get your Xbox product repaired

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

SoulDogWarrior actually was completely right.

I mananged to do the update by creating a different account and then logging it online, but now something stranger happened.

The 4gb internal memory doesn't show up as a storage device. If I shut down the console and remove flash drives before switching it on, the console shows no storage devices. It's obviously still working though.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Cokes123 yes i have the same console with the same problem almost!! I was on with support to nite for about 2 hours trying to fix issues im having with mine. My problem is when ever I try an watch a movie the error message pops up "storage device has been removed an console then has to restart" I can play games all day an never give a problem dont lose any gameing history works like new but put a movie in an u can forget it the console will keep poping up the same error an keep restarting. Seems we tried every thing all the way down to deleting an recovering the profile an still have the same problem they never one time said anything about sending it in an for a $100 THEY COULD REPAIR IT!! So if anyone has resolved the problem please inform me!!!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there Odin! This thread is pretty old. If you're having issues go ahead and make a new thread detailing your issue and any steps you've taken already to resolve it. That way we can personalize our troubleshooting to your exact issue. Thanks! ^_^

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.