"Group Not Found" ????

So i have a question for everyone how many of you are getting the "group not found error trying to get into the "Private Forums" for the Dash beta test? I know i am getting it and i dont know why ... is it because i never posted in this forum. i myself think that is just a bit silly. How many of you are excited to be gettin gthis Beta test? This will be my first beta test for MS and Xbox so i am kinda excited to be helping out.

 

Discussion Info


Last updated July 4, 2018 Views 1 Applies to:

Everyone is getting the same problem, just be patient and they should resolve the issue.

same problem here. i would imagine there is lots of work for them to do.

not much

I have a question. I just got a new xbox and had the beta on my old one. I put in the product key and it said it had been used already. I trued to request a new key and it said none were available.  Please tell me I can get the beta back on my new xbox!

[quote user="WickedxRhyme"]

I have a question. I just got a new xbox and had the beta on my old one. I put in the product key and it said it had been used already. I trued to request a new key and it said none were available.  Please tell me I can get the beta back on my new xbox!

[/quote]Sorry but this Thread is from last years Beta. To answer your question though, you do not need another Beta Key. Simply Download the Beta Update again from your Download History on your Profile you first Downloaded the Beta Key on the additional Console.

Thanks a lot! Sorry I didn't notice the year..but I am having the same issue with finding the group for this year

Please see this post.