Problem's connecting to xbox live parties and games

I am having some issues connecting to some friends parties and games.  I know specifically the issue lies in my router as when I directly connect the xbox to the internet without the router I have no issues at all.  I have a Belkin f5d7234-4 model router and I can't figure out how to get this thing to work properly with xbox live.  Any help resolving this would be greatly appreciated.

Things I have tried:

Port forwarding - I am forwarding ports 3074,88,80 and 53 to the xbox.  This has allowed me to have an open NAT but I still have issues connecting to some friends and games that I don't have when not using the router.  

DMZ -  When I put my xbox in a DMZ i am unable to connect to the internet.  

Settings I currently have enabled:

Connection Type - Dynamic

Security: WPA/WPA2

Authentication: WPA2

WPS - Enabled

Firewall - Disabled

WAN Ping blocking - Disabled

UPNP Enabling - Enabled

 

Question Info


Last updated July 4, 2018 Views 81 Applies to:

Belkins are weird. I know it sounds counter-intuitive, but sometimes you have to set up DMZ and port forwarding, or DMZ and UPnP set to enabled, or port forwarding and UPnP set to enabled. If none of those work, factory reset your router. If THAT doesn't work, replace that Belkin with a Netgear. The WNR2000v3 and WNDR models are perfect for the Xbox.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The Firmware is up to date: 5.01.14 (Oct 13 2009 22:59:20)

I have also disabled WPS still the same issue.  

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Greetings unnoan!

Appreciate if you could post up the make and model of your modem as well.

Visit the Belkin website and make sure your router is up-to-date with the latest firmware version. Since this router have multiple versions, make sure you select the correct version number.

[quote user="unnoan"]WPS - Enabled[/quote]Turn off/disable WPS and configure wireless settings manually instead (WPA2-PSK with AES encryption).

Post back and let us know how what you find out regarding the firmware version.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.