Private Beta Issues, too

I have had the beta tab on my console for about a month now, and have repeatedly tried to access the private forums. I keep seeing "Group Not Found". Thank you for your help!

 

Question Info


Last updated July 5, 2018 Views 0 Applies to:

Please hold tight Enlinia22 while forum support verifies the beta account then they will grant you access to beta forum thank you

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Enlinia22. You do not appear to be in the beta. Could you have registered under a different account?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi peeps, I have received all I need for the beta update but I cannot find the private forum to post my feedback etc etc in. Please would someone be able to assist me please.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

@DoggLegg76 - for future reference create you should create your own thread for your issue.  This thread is getting close to 3 years old.  

Here's the link you're looking for.

forums.xbox.com/.../default.aspx

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Cheers Onyx I didn't think about reading the date....... Lol ;)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey guys  I know this thread is old but I can't access the beta forum. Any help ??

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.