PLEASE HELP! I've tried everything I know to try

I have searched and searched and tried everything that I have come across but nothing has worked so far. Any advice/suggestions are much appreciated.

Thanks in advance!

Problem: Wireless suddenly stopped working. Currently have these two problems (Wireless) Can't obtain an IP address and (Wired - XBox to router) NAT Error
Connection setup: XBox 360 to DLink 625 Range Booster N Wireless Router (Wired/Wireless via internal adapter). I do not have a modem. The apartment is wired so that I just had to run the ethernet cord from a socket in the wall to the router. In addition to the XBox, I have a Window 7 desktop (wired) and Ubuntu 11.10 desktop (wired) connected to the router along with the occasional Ubuntu 11.10 laptop (wireless), MacBook Pro (wireless) and PS3 (wired/wireless).
What I have tried:
1. Restore default/factory network settings. Power down (wait 1 minute) and power up router. Power down/up XBox. No change.
2. Set static IP address, subnet mask and default gateway. Tried setting IP address inside and outside of the DCHP range (Why? For the sake of exhausting all my options). Restart router and xbox. No change.
3. Set primary and seconday DNS server. Note: I set both to the same address because when I run ipconfig /all I only get a single address. Restarted and still no change.
4. Set alternate MAC address. I set this to the address of my laptop. This allowed the xbox to get a little further but I then got a DNS Error and this also kicked my laptop off the network.
5. Switched to wired connection. Connects but has NAT Error. Says I will have problem with multiplayer/communicating with others.
6. Through the router setup, opened ports 53, 80, 1863 and 3074 (TCP) and 53, 88, 1863 and 3074 (UDP)

Additional info:
ISP is NuVision
Router has UPnP enabled.
XBox used to connect wirelessly fine.
PS3 connects fine but has NAT Type 2.

After running "Test Xbox LIVE connection" on wireless, here is the status with static IP address (outside the DCHP range), manual inputs for subnet mask, gateway, DNS gateways and the aforementioned ports forwarded:
W: 0000-0021
X: 8000-100D
Y: 0000-0000
Z: 0000-0000
ID: FFFF-FFFF
L: 8015-0002
Q: 8007-0435
T: Wireless
D: 192.168.0.1, 192.168.0.1
S: WPA
C: 8
 

Question Info


Last updated July 4, 2018 Views 5 Applies to:

Hi,

  • First of all restore your Xbox networks settings back to factory defaults and leave them like that
  • Secondly remove any port forwarding from the Dlink and keep UPnP enabled
  • Ensure your Dlink is using the very latest version of firmware (IMPORTANT) check the website for an update don't rely on a routers internal firmware update check
  • Try using WPA2-PSK(AES) for your security instead (make any changes like this when wired to the router not over wireless, this change will also mean any other wireless clients will have to reconnect to the network again)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Shad0wmanUK,

Did exactly what you said (missed the WPA2 (AES) part to begin with but fixed it) and worked PERFECTLY! No IP address error! No NAT error! Nothing! :) Apparently, I had never updated the firmware. Mine dated back to 2007. I really appreciate the quick response/help! Hopefully this can help others too.

-H

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Excellent :o)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Glad to hear it! Please feel free to rate your forums experience. :-)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.