Play & Charge Kit won't charge properly?

I recently bought the play & charge kit so I could charge my controller, via the console, and then use it wirelessly, once it has finished charging, however, I am getting a weird issue with it?!

.

I initially charged it via the console whilst I was playing, until the light on the kit turned green so I knew it was charged fully.  I then carried on playing with it (over the next week or so) until it ran out and needed charging again.  I then plugged it into the console again (the light on the kit went red to show it was in charge mode) and switched the console off.  The xbox then switches off but stays in  a low power state and continues to charge the controller until it has charged it (light turns green) and then shuts everything off properly.

.

The problem, however, is this: The last 2 times I have done this, the light on the play & charge kit literally turns green just 5 minutes after the xbox goes into its low power state. I know for a fact that the controller has NOT charged properly because the xbox has only been switched off for 5 minutes and there is no way the controller only takes 5 minutes to charge from being totally flat.

.

This is confirmed because if I then switch my console back on (after having removed the play and charge kit), the battery meter on the Guide page only shows 2 bars which is proof that the controller has not been charged properly?!

.

This has now happened twice and I really do not know why the xbox is turning the controller light green when it is obvious that it has not been charged properly?!

 

Discussion Info


Last updated July 4, 2018 Views 1 Applies to:

Try charging your xbox controller with a pc since the charger uses a usb port to connect to the xbox. If that doesn't fix it that means there's a short in the cable and you have to buy another cable. I'm pretty sure you will have to buy a new charger cable, but who knows. It is worth a try.