Party And Live Disconnection... And More!

Soo i have had this problem for about 4 months or so after i got my 4gb slim console and it's driving me crazy.. Here is what my problem is.. Certain games that require me to connect to server (Homefront, Battlefield Bad Company 2) when connecting to those games my xbox goes nuts kicks me from xbox live party then moments later join me back in to it and in some cases even kick me from live all together. I can still play battlefield so it is not so much of a issue and it only happens when i am making a connection to a games server like when i switch games in battlefield or when i enter the main menu. Homefront on the other hand. Will not even let me join a game and tells me the servers are down everytime i connect. When these games do this they always kick me from my xbox live party and then moments later put me back in it. My friends say it is messing with there gameplay with me entering and leaving the party so much.. I almost never get disconnected from live altho sometimes it has happen. I have tried a long list of things on my end to fix it.. I have tried rebooting over and over again my xbox and the games. I have tried checking out my router and as far as i can tell the xbox is allowed all incoming and outgoing traffic without limits and my internet connection is the best they offer in my area. I have tested my internet lines and my wireless on my router by pluging in the xbox. No matter what i do nothing changes my computers work fine and in some rare instances it has been known to crash my internet connection while trying to connect to game servers(My internet quickly reboots it self after and resumes as normal).. If someone else knows what this is please help me.. It's so bad that i am scared of buying games thinking they will be like homefront and not work at all online.

 

Question Info


Last updated July 4, 2018 Views 3 Applies to:

It sounds like your internet connection might be strained by trying to play these games on LIVE. There are a few more questions here that you can answer, to better help us help you. Also, can you please run a connection speed test from your PC, and then post the results in your thread?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.