Odd connecting errors.

This morning, I decided to join a party with a friend. Since I had Moderate NAT at the time, I decided to fix it to Open by doing my simple method of disabling my wireless on my laptop, resetting my router and waiting 1 minute.

Instead of working like it normally does, I only connected to my network and internet, but not Live. It said that I do not have a sufficient MTU setting. Problem being, my MTU is already on Auto. I tried it on the max (1500) and Auto, but neither worked. I've done every trick so far to try to connect, but it hasn't worked; resetting my network hardware and retrying, waiting 1 minute after resetting router, restoring defaults on my Network configuration settings on Xbox, etc. I've been trying for a good 7 hours, and I would really like some help.

Also, if it helps, I have Comcast internet, and a Linksys router.

 

Question Info


Last updated July 4, 2018 Views 1 Applies to:

MTU is something provided by your internet service, in this case, Comcast. You'll need to contact them and let them know about the issue. You can also follow these steps to see if they help: support.xbox.com/.../connect-xbox-live.aspx

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.