New Xbox Slim won't connect without "testing connection" first

I have a DGL-4100 D-Link router set for a static IP address in the Gaming section of the router setup for my Xbox Slim. Ports 53, 80, 88, and 3074 have been opened for the static IP address to use for TCP and UDP protocols as necessary.

The Xbox Slim "network setup" is set to the same static IP address that was used in the router. The DNS setting was left on "Automatic".

 

The problem is that when I start the Xbox Slim, it goes to a "non-connected" screen and when I select a Gamertag to sign into, it says the connection cannot be made and I should test the connection to Xbox Live.

 

When I test the connection, it always connects and stays connected until I turn the Xbox Slim off. It then will repeat the scenario described above again (and everytime I shut off and restart the Xbox Slim). It will not simply connect when I select my gamertag to sign in without "testing the Xbox Live connection".

 

My old Xbox 360 did not have this issue.

 

In addition, my old Xbox would automatically sign my gamertag into Xbox Live when the Xbox was turned on. How do I make the Xbox Slim automatically sign my gamertag into Xbox Live once the above issue is corrected?

 

Thanks in advance for your help.

 

Question Info


Last updated July 4, 2018 Views 9 Applies to:

In your D-link router setup, you will need to specify DNS settings under DHCP server if available.  I usually troubleshoot linksys but I would assume it would be similar. If I run a manual IP, I cannot run an automatic DNS unless I push it through via DHCP.  The best advice would be to manualy add in your DNS using the same numbers your router would.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks so much! Specifying the DNS (primary and secondary) worked as you said. I failed to mention on my old Xbox I had set these manually, but figured the "default" screen view when changing the IP address would force the user to manually input the DNS servers too if it really needed to be input manually... my bad. Should have known it wouldn't "think" for me.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm happy to hear things are working as they should now.  If you need anything else, let us know.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.