New tv not playin CoD well plz help

just bought a new 60 inch sharp led flat screen. Its nearly impossible to play, nothing flows smoothly and I cant get anyone in my sights. Never had this problem on my 32 inch and it is 5 years old and cheap. Really bummed out cause I dropped 1800 bucks on this thing. Its 1080 and 120 refresh I thought it would play fine. I dont have an hdmi cable to run the 360 to it yet dont know if thats a problem or not. Any insight would be helpful otherwise im takin this thing back.

 

Discussion Info


Last updated July 4, 2018 Views 0 Applies to:

Well can you post the TV model number that will help so I or someone else can look at the user manual and give you really specific advice. What I can tell you what you should try to do is go into the menus and disable any image enhancement effects. All of the enhanced color, adaptive brightness, smooth motion all of them. If that doesn't work check the menus for a game mode which some TVs will have that automatically turn off features that could cause issues with games.

LC-60LE632U

thx for the help btw smiling cat. Well it did have a game setting, and it did make the game instantly playable. but it looks terrible graphically, i mean it is far worse than my 32 in 5 year old off brand bad. doesnt even look HD. So kinda a toss up, looks great but not playable or looks terrible but playable. Any more help would be super appreciated, somewhere in the middle maybe.

Yeah that is just something you will have to live with. Unfortunately the 360 and PS3 are underpowered to run a majority of games at full 1080 resolution. Most of the time you get a 720 resolution which is then scaled using some form of extrapolation. The bigger the TV the more obvious this is. Geometry aliasing or jaggies is probably the biggest and noticeable rendering artifact in games because they would run at slideshow frame rates if they used anti-aliasing.

Also with a screen that size you want to be at least about 8' back from it.

man that kinda sucks. well thanks for all your help. I did keep fooling with it and got it looking somewhat better but still playable, just not what I really expected. thanks again.

Bigger is not always better. :p

Well yeah it sucks, but know you will be all set to enjoy full 1080p graphics on the next Microsoft console for sure.

I would suggest using the Movie or Cinema picture mode and then disabling LG's TruMotion feature. Things like edge enhancement and dynamic contrast as well as any colour enhancements should also be disabled.