New TV No picture (HDMI)

hello

I have just got a Sharp Aquos 37inch full hd tv and with HDMI i cant get a picture or sound at all. the xbox knows that it is plugged in and on the right channel because it boots up(lights on console flash as if its loading up)

It never worked on the last dashboard or the new update one.

I have tryed all the video reset option and my TV is HDCP compitable. it works on my old 32 inch samsung with no problems. i have tryed 3 different HDMI cables and even done a full restore on the console useing a scart cable to see if it fixed with no luck.

Needless to say i would rather not play my xbox in SD quality lol

Hope someone can help

Ben

P.S I have a HDMI Arcade edition Xbox

 

Discussion Info


Last updated July 4, 2018 Views 0 Applies to:

[quote user="FlappySalmon"]... the xbox knows that it is plugged in and on the right channel because it boots up(lights on console flash as if its loading up)...

[/quote]Not sure what exactly you mean by this. Is your TV on the corresponding input? e.g. if you plugged your Xbox into one of your TVs HDMI ports (say HDMI 1 for example) you must change your TV to that input/source before you will see or hear anything.

Yea it is on the Right sorce channel and i have tryed it on all three. i have no problems on any other TV. i also tryed a new Slim Xbox and that work perfectly fine. im very confused :( all other HDMI devices i have tryed work with no problems

Have you tried disabling display discovery on your 360? Could be your that your TV is sending bad info to the 360 or the 360 is misinterpreting the EDID info.

yea i pluged it in my other TV and disabled it then plugged it back in my new tv and no luck

It could be a defective HDMI port - it happens. Call the manufacturer and see what they say.

There could be a handshake problem between the display & the 360. Try turning them off & on in different orders. Since it would seem you're connected directly from the 360 to the TV, there's only a couple of options... TV then 360 or 360 then TV. I'm guessing at some point you've probably already inadvertently done this, but in case you haven't, give it a try.

 

Have you tried connecting any other HDMI device through this port? Doing so could help eliminate the TV's HDMI port as a problem.