New 360 s graphical glitches

I sold my old Xbox 360 Arcade with a 60GB HDD, and got myself a brand new 360 s with 250GB. I've noticed some weird graphical glitches in several games, like these white dot outlines in Battlefield 3:

bit.ly/vRVLYx

I've never noticed something like that with my old 360. I only got myself a new 360 cos I need more HDD space, and I'm beginning to regret that decision as I had no problems whatsoever with the old one. :( Do I need to send it in for a repair, or can I just get a new one at the retailer?

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

I played GoW, Crazy Taxi and Perfect Dark last night, and all of 'em had these white dots somewhere in the graphics. Like EffEmmGee says it's like the polygons isn't sitting entirely flush with the surrounding polygons. It's a common problem with all games it seems, and I've 100% never experienced it with my original 360. As I've been playing games for so long on my original 360, the differences in the graphics are quite noticeable, I swear it looks like games on the new S console is lacking anti-aliasing.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think the question you need to answer is if these games are having the same issues on original 360s.

I threw Battlefield 3 into my rental queue at GameFly. I can try testing it when it shows up, but so far I've seen no difference between how 360 S and original 360 consoles render games.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I took the console back to the store and got a new one. The problem with the graphics is the same on this one. I've been using the old 360 model since launch, and playing on the new S model I'm noticing a lot more aliasing, and the problem the video shows of the graphics in Battlefield 3 is the same in many older games, something I've never noticed before. The first S console was glossy and manufactured in January 2011, and the new one is matte and manufactured in September 2011. Have I just been unlucky twice with two consoles manufactured 8 months apart, or is the graphics chips in the S consoles inferior to the old 360's? I'm very disappointed with my purchase right now, I should have just gotten a bigger hard drive for my old 360. :(

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

After looking at that YouTube video it just looks like a Polygon (in this case the Celing) that isn't sitting entirely flush with the surrounding Polygons (the Walls).  It's fairly common in games but it shouldn't be, should be caught in testing really.

So from what it looks like to me you just found a polygon that's not flush with the rest.  Looks to me like it's the game and not your console.  I don't have BF3 yet but maybe if you asked someone or a friend you know with it to go to the same spot and see if they see what you see.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I use my old component cable, and I've never had any problems with it. I don't see how the connection has anything to do with graphics acting like that, anyway. (did you see the video I've uploaded on YouTube?) As far as I know, a bad connection would affect the entire picture quality.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Have you tried a different HDMI cable or another input on your TV?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi all, thanks for responding. I've noticed it in Code Veronica X HD as well. I can't imagine it's anything to do with the connections, as everything else looks fine.

I see the link didn't work, here's the correct one: [View:http://www.youtube.com/user/MegaMrBurger#p/u/0/C-LYdLQpyUw]

Is this something anyone else have experienced?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Did you install the 1.5gb hd map pack - I found this to fix the lack of bitmaping on objects, I also have a slim, HDMI, LED TV

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi, did you check if all display settings are correct?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Do you get similar issues with other games as well? Have you confirmed it's not just a bad copy of the game you are playing?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.