Netflix video quality on X1

Hello I did a search and couldn't find a relevant post.

Does anyone else have issues with the video quality from Netflix on X1?

I can rent XBOX Video movies and watch them streaming in HD, but the Netflix quality is just horrible. Is there something in the settings that I am missing?

My connection isn't an issue, ~65mps through a Net Gear R6300

Any help would be greatly appreciated.

 

Discussion Info


Last updated July 4, 2018 Views 6 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

No problems here.

no issues here as well and i have a 25mps

The picture will vary depending on how well the video is buffering at the time. I often find that the first few minutes of anything I stream can be a little sketch with constant shifts from glorious HD to something that looked bad on Youtube 5 years ago. After the first few minutes it all seems to settle in to good quality HD video.

-

If you're only having the issue with Netflix then the issue could be on their end, perhaps a high traffic time of day. Sometimes though, if this problem happens to me I turn the Xbox off and use my Smart TV instead. Do you have anything else you could stream Netflix with?

Dynamic Sausage, Thanks for the response

I usually go to my Wii U when the X1 gets bad.

-

I was just hoping that there was some random item in the settings that I didn't check. haha

When I watch movies on Netflix with my xb1 its hd but runs the movie at like 10 fps its really bad. I switch to my 360 and it runs the movie flawlessly. I have great internet, I don't know why this happens.

By the sounds of it, everybody is having similar problems that go away when they use something else. Hopefully we'll see a software patch soon and our troubles will be over.

Same for me.  Netflix on my X1 looks like crap and never seems to go HD and buffers frequently.  If I switch over to my HTPC and use Netflix within Windows Media Center it goes HD after about a min and then stays there the entire time without buffering.  

same here, may or may not be related, but i noticed a degrade in quality after i setup the port forwarding on my router to get the NAT open.

I'm going test this, this weekend, I usually don't watch Netflix on X1, I will post results

Awesome Karma, let us know!

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.