Nat strict and losing connection during 1 game mode only

Ok, I've made a post before about my nat being strict, don't know how to find my old posts anymore, but I did everything everybody told me to do and I could not get my nat open no matter what I did, so I just kind of gave up because I was having no problems joining and playing games, just maybe couldn't hear certain people talk, which I guess is because I can only hear people with their nats open since mine is strict. That didn't bother me too much so I gave up on that because all it was doing was stressing me out. Well now I just purchased Onslaught mode for Bad Company 2, I either can't join the game because it says I don't have a connection, or I can join but I get kicked out literally 3/4 of the way through the level because I've lost my connection. Now I know there's nothing wrong with my connection because I can play any other online multiplayer including all the Bad Company multiplayers without any problem whatsoever. The only mode that is giving me trouble is onslaught mode. Now I don't know if this is because of my nat being strict, but I don't understand why this is the ONLY mode that is giving me trouble.

What Country/State/Province do you live in?  New York, USA
Modem brand & model number: 
**** TM502G
Router brand & model number: 
Belkin F7D2301 v1
Network Connection Type: 
Wired

Things you have tried: Too many to list and remember, literally everything that the troubleshoots say to do and everything everybody else said to do for the nat setting. Currently nothing for the connection problem because I don't know what the problem is.

Is UPnP Enabled?  Yes

Is NAT Type Open? Strict

Any Error Codes you encounter:  Connection Problem, Connection to the game service has been lost. Please check your network connection and try again. (Only during Onslaught mode on Bad Company 2, absolutely no other mode or game as of yet)

What type of internet do you have?  Cable

Who is your ISP(Internet Service Provider)?  Road Runner

When you run "Test Xbox LIVE connection" what is the exact message shown on screen? Connection Warning, You can connect to Xbox Live, but your current network configuration may limit your online experience. Select more info for a description of the problem and how you can fix it. (Now of course I did everything the more info told me to do among many other things with no luck.)

 

Question Info


Last updated July 4, 2018 Views 26 Applies to:

Hi,

 

This is very common with Belkin N's follow this guide to the letter and it should resolve it:-

 

www.unofficialguidetolive.co.uk/.../62-my-nat-is-strict-or-moderate

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I did everything it said to do. I've tried setting up a static IP address numerous times on the Xbox, every single time after I do it I can't even connect to live anymore.  I've gotten directions on how to do it from numerous sources and I get the same results every single time. When I test my live connection I get "Test Failed, There's a problem with your connection. Select more info for a description of the problem and how you can fix it. Again, I do everything in the more info, still no luck. This is getting unbelievably frustrating because I don't understand why I'm still having problems when I'm doing everything that everybody is telling me to do. Wasn't so bad until I can't even play the Onslaught mode that I just bought.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Belkin routers aren't very good IMO for this reason alone. Are you running the latest version of firmware on the router? Check their website don't rely on the router sayings its up to date

 

I'm surprised its still a problem though, if you follow those instructions to the letter and have UPnP turned off and any portforwarding turned off it should work,

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Oh my god, wait... I just realized I messed up on the DNS part of it and all of the other times I've done it they've never said anything about changing the DNS away from automatic, soi that had to have been my problem... I'm connected to live now through the static address with an open nat right now, BUT every single time I do something new, my nat IS open right after and sometimes even lasts while I play through a couple games.  So I'll have to get back to you tonight and let you know if it's still open.  If it is, THANK YOU SO MUCH... This has been so frustrating and it turned out to be 1 extra stupid step.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Ok

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Ok, so far so good, been playing onslaught without a single problem... Like I said, I've done things before where the nat setting would go to open for a bit, but then sooner or later it would be strict again, I should know by tonight though, wouldn't last any longer than that before.  Thanks a ton. Now I've always been told to have the upnp on, why is it ok to have it off now?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Could anything I've done there effect a blu ray player being able to play netflix connected to the same router? I've never had a problem with it before, now I can connect to netflix, see all the movies and stuff in my queue, but none of them will load and play.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

 

Good stuff, when configured in the DMZ properly it should never change, UPnP, DMZ, Porforwarding all do the same job for the Xbox so if you have them some of them configured at the same time they interfere with each other

 

I don't know much about your blu ray player or Netflix I'm afraid. Does it need certain ports open to be able to contact the service (I assume this is nothing to do with Xbox?) if the player does need certains ports open yes UPnP may have opened them for the player if the player is using UPnP as well. If that is the case its a matter of finding out what ports are needed to be open for your player and setting up portforwarding for it.

 

Just done a quick search about this and Try this:- http://portforward.com/english/routers/port_forwarding/Belkin/F7D2301v1/Netflix.htm

 

If that causes problems with anything else don't both forwarding port 80 and just forward 443

 

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

What I was asking is if doing what I did to fix the Xbox could have affected the Blu Ray not working because it never had any problem before I changed the setting on the router when I was fixing the Xbox but it must have just been some problem that specific day...  I just went to check and see if it still wasn't working before I messed with the port forwarding stuff and it's working fine now.  Thanks A LOT for the help, I can't believe how simple it ended up being with just 1 link. I've looked up so many different things, asked a lot of people, got so many different answers, I can't believe it's finally fixed. Really, thanks again!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

No problem

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.